Lonely Cat Games

- entertainment and productivity on mobile devices -
It is currently Wed Jun 19, 2019 12:10 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: 2 Questions Concerning Encryption
PostPosted: Wed Oct 03, 2018 6:41 pm 
Offline

Joined: Wed May 18, 2011 5:34 pm
Posts: 41
First, let me tell you, that I'm still a fanboy of profimail go after such a long time. No other mail program for android fits my needs with so many accounts and large folders so well.

But with encryption I encountered some small problems recently, and so I have two questions. Maybe, somebody reads still here..

The answer would help me to know, if I should do further experimenting with the certificates, or if I can stop this, knowing that these issues are related to profimail go.


I want to add in advance, that Thunderbird didn't have these two problems, with none kind of the tested certificates.

The scenario:
- Self made certificates, signed with own (also self made) CAs (for me and my opposite mail partner)
- A self made user certificate for my mail partner, containing two mail addresses for the same domain (and the same mail account (it's a catchall, multidrop account, so both mail adresses are connected to this one account).

My partner and I use both profimail go and Thunderbird.

The two small problems:


A) Self signed CAs not recognised

After importing the CA Certificates (own and foreign) into the Android certificate store, PMgo seems not to recognise these CAs. Maybe, because Android imports them to User CAs and Profimail checks System CAs only?
- The effects of this are:
-- Signatures can not be validated
-- Foreign public certificates are not imported automatically. (I guess, that this is the reason for the missing auto-import after while reading a signed nessage (?))


B) Multiple Mail adresses in certificate: only the first one is recognized

Is it possible, that PMgo recognises the first e-mail adress contained in a user certificate only?
While Thunderbird encrypts for both adresses, PMgo behaves as if there was the first adress in the certificate only.
I tried one e-mail adress in the subject area of the user certificate, and one as alternate e-mail adress. And I tried another user certificate, where both e-mails ar stored in the alternate section only. Thunderbird uses both adresses in both cases, Profimail the first adress only in both cases..

Of course I do not expect, that you will spend time into pm go anymore, after the program became free. (Despite it would be nice and I would pay a small amount especially for the CA "thing". ;) )

But any clarification would be helpful to me, so that I do not have to experiment with my certificates any more.

(Or vice versa: Maybe PMgo works fine and I have to fix
the certificates in a special way?)


Thank you very much
Knut


Top
 Profile E-mail  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group